Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555

Let’s encriptの導入でcertbotの実行時エラーを返すようになったのでその解決法

 
# certbot certonly --webroot --webroot-path /var/www/html/ -d domain -m email@yahoo.co.jp

An unexpected error occurred:
The client lacks sufficient authorization :: Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555
 

certbotをここから入れ直す。単に上書きで入れていい。
https://certbot.eff.org/lets-encrypt/ubuntubionic-apache

Choose how you’d like to run Certbot
Either get and install your certificates…
Run this command to get a certificate and have Certbot edit your Apache configuration automatically to serve it, turning on HTTPS access in a single step.

 
$sudo certbot --apache

Enter email address (used for urgent renewal and security notices)
メールアドレスを入力してください(緊急の更新およびセキュリティ通知に使用)  入れてEnter
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(A)gree/(C)ancel: a   ← 承諾する

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(Y)es/(N)o: n	← その他メールはいらない

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you're confident your site works on HTTPS. You can undo this
change by editing your web server's configuration.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 2  ← 2 httpsを強制する

で終了

つづいてApacheのSSL設定

# vi /etc/apache2/sites-available/default-ssl.conf
以下はこちらの記事の通り
 

Linux

Posted by 太平洋